McLaren Life banner

21 - 37 of 37 Posts

·
AliB
Joined
·
51 Posts
As a guess from one prior experience:
Please try opening and "firmly" re-shutting the engine cover but DO NOT slam the cover down, just make sure it is latched on both sides.
It "might" be that one of the engine cover latches has had an "out of the box" failure which will not show on the dash and this can only (sadly for your distance) be replaced by the dealer.

I hope you are enjoying the car and some good weather whilst the roof is down!
Best regards - Alastair Bols
 

·
Registered
Joined
·
271 Posts
My roof did not work the other day and the service manager asked me to press that reset button and it work perfectly after that.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #23
You bought the wrong car. You should have bought that Fiat I showed you!!:D:D;)
The "Fiat!" Haha! If I had gotten the Fiat I would have had to keep the top down so everyone could see me:D
 

·
Registered
Joined
·
201 Posts
Discussion Starter #24
My roof did not work the other day and the service manager asked me to press that reset button and it work perfectly after that.
I wonder if this is a relatively common issue?
 

·
Registered
Joined
·
314 Posts
I wonder if this is a relatively common issue?
You mean with overly complex software and mediocre hardware? Then sadly yes, it is common. Usually reboot/reset is step 1 with any product support diagnostic flow. Step 2 would be a reinstall, but that's out of our control.
 

·
Registered
Joined
·
43 Posts
Hi Guys, i seem to have this problem now. the roof will not open, it says tonneau cover empty, i confirm and nothing happens.....

how do i do the reset on this?

thank you
 

·
Registered
Joined
·
43 Posts
does anyone know this? mine keep playing up, starts to go back, then stops and have to keep pressing the switch to get it to open.
 

·
Registered
Joined
·
622 Posts
does anyone know this? mine keep playing up, starts to go back, then stops and have to keep pressing the switch to get it to open.
For my 650s, I had to hold the key until fully open. Not sure whether that's what you meant by keep pressing the switch.
 

·
Registered
Joined
·
43 Posts
no i know how to work it, its just when i keep it pressed it stops through the cycle and then you have to let go and press again... closing it is fine, only when you try and open it.....
 

·
Registered
Joined
·
622 Posts
no i know how to work it, its just when i keep it pressed it stops through the cycle and then you have to let go and press again... closing it is fine, only when you try and open it.....
Ah. Thanks for clarifying. Unforuntuately, I don't have anything to add.
 

·
Registered
Joined
·
38 Posts
With such widely spaced dealers, I do wonder why they have not invested in a mobile diagnostic team that can come and plug in their computer and "see" the problem and if it is an easy fix such as a fuse or sensor do it there and then.

In the UK the AA do the cover they came to my house and rebooted the car took 1 hr they cam with laptop and direct line into mclaren tech shop
 

·
Registered
Joined
·
1 Posts
They may have already mentioned it but, have you tried a push and hold reset? It's solved all sorts of problems over the months and years....
Hey, where is the push to reset button. I’m having the same problem on my 600lt
 

·
Registered
Joined
·
581 Posts
Hey, where is the push to reset button. I’m having the same problem on my 600lt
It's similar to how you reset an electric window. Just push the button all the way (It's the same button that operates the roof) when it's completed then keep it pressed for another 5 seconds. then do the opposite, pull it up and when it's fully completed and finished the cycle then keep it still pulled up for another 5 seconds. That's at least how I calibrate and reset them and I don't know whether there are other methods.
 
21 - 37 of 37 Posts
Top