McLaren Life banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,925 Posts
Discussion Starter #1
Has anyone had to replace IRIS due to catastrophic failure, once or more? Ive just had it die a second time within a few hours of a new unit being installed.

So last week my IRIS seized up at the "McLaren" boot screen and simply would not get past that screen no matter how many times you try to reboot it.

Today I went to McLaren Philly and they replaced IRIS for a new unit (also got Xpel on the lower part of the bumper (which oddly isn't normally covered) and on the carbon fiber air brake). Nick did the work and he's amazing. Highly recommended.

Anyway, Kevin H. & Matt were epic and (in addition to fixing a pesky rattle and replacing some parts), installed a brand new IRIS system.

As I'm driving home, things seem to be working, I've connected both my iPhones and one iPod, and for some reason my NAV freezes and the phone pairing, unpairs. I reboot IRIS 2 or 3 times as it isn't connecting to the iPhones for some reason, and then on th next reboot of the system, frozen screen of McClaren death.

I'm at a loss as to what is causing this. The phones and ipod were used with IRIS for months with no issues. The only thing I can think of, is there is some problem with version 12 of IRIS that it can get corrupted. That seems to be the only change. What's worse is that prior to this, Version 12 was working really well for me, to the point that i was using it regularly. I'm suspecting that something about version 12 doesn't like to be reboot and causes permanent corruption when it shouldn't.

Any experience with this or thoughts as to what may be causing the stem to lock up? Thanks!
 

·
Registered
Joined
·
123 Posts
I think your car just really wants the new IRIS instead... give in to her needs and see if you can't get one of the first retrofit units (I'm sure you would if you could, but worth giving it a go!)
 

·
Registered
Joined
·
1,925 Posts
Discussion Starter #3
I think your car just really wants the new IRIS instead... give in to her needs and see if you can't get one of the first retrofit units (I'm sure you would if you could, but worth giving it a go!)
Yea, I asked if they could do so, and they said they couldn't. I guess I can ask a little more, or worse, have to ask them not to give me a version 12 IRIS as it seemed to not lock up before that update. :(
 

·
Registered
Joined
·
1,449 Posts
Yea, I asked if they could do so, and they said they couldn't. I guess I can ask a little more, or worse, have to ask them not to give me a version 12 IRIS as it seemed to not lock up before that update. :(
if your dealer told you the new system cannot be retrofit into the 11/12/13 cars, they are wrong.
 

·
Registered
Joined
·
1,925 Posts
Discussion Starter #5
Declan, no, they just said they wouldnt be able to get a new unit until october/november. They will be able to put the new units into older Macs.
 

·
Registered
Joined
·
239 Posts
My IRIS has been satisfactory, not perfect but nothing like your problems. Pairs with my one iPhone reliably, plays music from my USB memory stick and omits key turns in navigation.
 

·
Registered
Joined
·
1,925 Posts
Discussion Starter #7
Good to hear Kverges. Mine was much the same, and since the 12 update, it's been way better, well barring 2 catastrophic failures. Will see if they can figure out what the deal is...
 

·
Registered
Joined
·
17 Posts
Last year, shortly after purchasing my Mac (used), the IRIS (head unit) began rebooting. It would work fine for the first 15-20 minutes of driving, and then begin cycling (rebooting) every 3-8 minutes or so.

I was initially told it was a blue tooth connectivity problem some people were experiencing when their iPhones were connected (which sounded like complete BS). However, unpairing my iPhone didn't fix the problem.

So the dealership had me bring the car in (which is a huge pain in the ass, given that I'm about 340 miles from the nearest dealership). They were pretty sure the IRIS system needed an update applied. And, unlike some vehicles, where that can be applied by the owner, a Mac's can only be applied by the dealership.

So they applied the update, drove the car around, and it was still cycling every few minutes, once the car had been driven for awhile.

Ultimately, they had to replace the entire head unit. Since they did that, I've had no real problems, other than the system losing track of the last radio station setting, etc.

I haven't had any other problems (until yesterday when my left rear turn signal light just fell out of the fender for no apparent reason)...
 
1 - 8 of 8 Posts
Top