McLaren Life banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,330 Posts
Discussion Starter #1
just got back from a couple of long trips in the Mac, putting about 1000 miles over the last few days. This was my first real opportunity to use the GPS for locating destinations. It was not a happy experience, so I'm interested in knowing whether other owners have the same issues I had. Specifically,
1) the resolution of the GPS must be no better than about +/- 100ft, when driving on the freeway, the arrow icon would constantly 'leap' off the freeway onto the feeder road or an adjacent county road. This caused the navigation system to be constantly telling me "re-calculating" and then asking me to turn back onto the freeway. this must have happened at least 50 times.
2) mostly when first starting up, the navigation would get totally lost, freeze up, show the car in the middle of a field, point it in the wrong direction etc. Sometimes this would rectify itself after a few miles, other times it would go on for the entire drive. This happened at least six times, and at one time I swear it had me in Vermont, even tho' I was in San Antonio!
3) the arrow icon would 'stutter', leaping backwards and forwards in one place, then suddenly jump to where it was supposed to be, only to begin stuttering again. This happened at least six times.
4) when entering a destination, the list of States would compress, showing only up to 'N', and past 'V' omitting all the ones in between. Being in Texas, this obviously caused issues trying to put in an address! This happened twice
5) even when the system's arrow was showing the correct location, the map itself would come and go, so that, e.g. a freeway would alternate between two lines and one line, and the background would go partially or totally blank
All in all, a piss-poor system. Is it just mine that needs fixing or are any of these problems familiar to others?
 

·
Registered
Joined
·
17 Posts
I had some of the issues you described, with the worst being that the system would lock up or reset. Had the dealer talk to a McLaren tech who suggested unpairing the bluetooth from my iPhone. Apparently, there are some "issues" with the current iOS + Mac bluetooth pairing that can cause the system to lockup. The "word" on the fix is that it should be addressed in the next iOS and/or the next McLaren software update.

I didn't have much problems with the other GPS behavior you describe, but for the most part I was driving on the interstate, so it's not like I was pushing its back-roads limits...
 

·
Registered
Joined
·
964 Posts
Yes, I had many of the same issues as mentioned, the car is booked in next week for the latest upgrade for the IRIS and a door adjustment whilst there...

The more I use it though the better and more stable it's becoming :eek: it even got us to a restaurant perfectly last night- it was a POI which impressed the wife :)
 

·
Registered
Joined
·
2,650 Posts
just got back from a couple of long trips in the Mac, putting about 1000 miles over the last few days. This was my first real opportunity to use the GPS for locating destinations. It was not a happy experience, so I'm interested in knowing whether other owners have the same issues I had. Specifically,
1) the resolution of the GPS must be no better than about +/- 100ft, when driving on the freeway, the arrow icon would constantly 'leap' off the freeway onto the feeder road or an adjacent county road. This caused the navigation system to be constantly telling me "re-calculating" and then asking me to turn back onto the freeway. this must have happened at least 50 times.
2) mostly when first starting up, the navigation would get totally lost, freeze up, show the car in the middle of a field, point it in the wrong direction etc. Sometimes this would rectify itself after a few miles, other times it would go on for the entire drive. This happened at least six times, and at one time I swear it had me in Vermont, even tho' I was in San Antonio!
3) the arrow icon would 'stutter', leaping backwards and forwards in one place, then suddenly jump to where it was supposed to be, only to begin stuttering again. This happened at least six times.
4) when entering a destination, the list of States would compress, showing only up to 'N', and past 'V' omitting all the ones in between. Being in Texas, this obviously caused issues trying to put in an address! This happened twice
5) even when the system's arrow was showing the correct location, the map itself would come and go, so that, e.g. a freeway would alternate between two lines and one line, and the background would go partially or totally blank
All in all, a piss-poor system. Is it just mine that needs fixing or are any of these problems familiar to others?
Boy oh boy tex that sounds extremely frustrating, I'd be pretty pissed off with a system that was not functioning to its full potential. I mean how freaking difficult can it be to resolve these software and or hardware issues. I wonder how many of these issues Ron is aware of, and if he's aware, how long would he be willing to live with them. I mean Navi has been around for over 10+ years, it's not like it's something brand spanking new. Honestly I really don't care that much about the Navi system, although it would be nice to have something that truly functions properly. I've got my fingers crossed for all of you guys out there that are trying to cope with these inefficiencies, hopefully Woking will come to the rescue. Cheers.....??
 

·
Registered
Joined
·
1,523 Posts
Easy fix, Iphone 4S and free Mapquest app. Still frustrating, but at least you are close to a Dealer to get the next update quickly.
 

·
Registered
Joined
·
551 Posts
Many have these issues with the Nav and I'm interested whether that latest update does the job. This update is 4 weeks available no?

Can you guys with the update join in and give us your experience? Does it still let you drive by the exits, does it count back on the highway?
 

·
Registered
Joined
·
1,330 Posts
Discussion Starter #10

·
Registered
Joined
·
1,330 Posts
Discussion Starter #11
Easy fix, Iphone 4S and free Mapquest app. Still frustrating, but at least you are close to a Dealer to get the next update quickly.
Err, not really, my dealer is a $650 truck ride ( each way) away. I used Google Maps on my phone to get to places as the Mac system was definitely not trustworthy. Given the distance to the Dealer, this is something I'll have to live with until ( hopuefully) its second annual service next year
 

·
Registered
Joined
·
173 Posts
I used the Nav for the first time this weekend on a short trip 100 mile trip..it was a disaster. Not only did it provide incorrect instructions but it continually recalculated the route..I finally turned it off and we used a phone app..
I am very disappointed as I felt these matters would be completely resolved by now.Iris was a year late and regardless of the upgrade consideration...it should be operating correctly by this time...
 

·
Registered
Joined
·
551 Posts
Iphone 4 with Tomtom on it. Works perfectly.
 

·
Registered
Joined
·
551 Posts
Oil pressure gauge, DAB tuner, TV module, bluetooth streaming, 3D coverart, you name it :)

BTT: Took the car for a 300km ride today and achieved a new personal record. Had to reboot the navigation system for 11 times during that journey but at least it got me there in the end :rolleyes: :D
Mcdc are you sure it was a 300km journey or it simply took 300km. With Tomtom it was perhaps only a 200km drive.
 
1 - 18 of 18 Posts
Top