McLaren Life banner

161 - 180 of 208 Posts

·
Registered
Joined
·
201 Posts
Bedding in brake pads whether stock or CCB is simple. They say to "Avoid hard braking" because while the pads are bedding in you can get pad outgassing and fade. I tracked my 570 GT with 800 miles on it and I had some pedal fade. but after the brakes cooled and I flushed the fluid with Castrol SRF and now the brakes are fade free.
 

·
Registered
Joined
·
201 Posts
Newbie here. Just took delivery of a pre-owned 2018 570S spyder. Car has approx 1800 miles and just completed its 1st year service.

I have a few gremlins that have popped up.

Car would not start. It would recognize the key, but would not turn over. The gauges would act like the car was attempting to start, but nothing. After multiple attempts over an hour period of time, I did get the car to start.

Parking Brake will not manually disengage and the light stays on all the time. I can drive it, but the indicator is red and says the brake is not engaged, however it is when the car is off.

Key not found in vehicle. After my not starting issue, I replaced the fob battery and the display says key not found. However the vehicle starts, etc. The left lever to access all menus is completely disabled and will not allow me to change anything or access error codes.
Cruise control error code.
I had one of my key fobs go bad, replaced under warranty but rather disconcerting. These cars are very voltage sensitive. Leave the car on a trickle charger when not driving it. It is just safer that way.
 

·
Registered
Joined
·
34 Posts
Car is back, all is good. Parking brake switch was broken (valet issue), battery almost completely drained, which caused numerous fault codes. McLaren Roadside was great, got to my local dealer and they were very thorough in getting the car back on the road. Nothing but high praise for both Chicago McLaren and Scottsdale McLaren for the help.

My newbie lesson, don't let valet's park your car, make sure the charger is on it. And don't freak out about little "personality" issues...
 

·
Owner
Joined
·
503 Posts
Welcome to McLaren! You will love the car.

Valet? Seriously. Why on earth would you let any of the folks get near your car? If I have to wrestle with the valet folks, I tell them where I am parking it (out front). Keys come with me. I'll pay them, but nobody touches the car, let alone drive it.
 

·
Registered
Joined
·
8 Posts
I washed my new-to-me 2016 570S for the first time today. All of the sudden the driver side window went completely down, and the button to open the driver door is no longer working... If i try to raise the driver side window it responds normally but immediately goes back all the way down when reaching the top or when i release the button.

I tried locking, unlocking, holding the remote lock button for a whole minute, trying with the engine running, closed the door with soft close and firmly all the way, tried the window position re-set by holding both window switches down for 5 sec and then up for 5 sec. Nothing works. Plugged in OBD2 adapter and no fault codes are present.

I have been out driving for like 6 hours before the wash so the battery should be fully charged.

There are no fault codes visible on the dash, though earlier today while driving i got a "Battery management active" message but i had been driving for hours and the battery is almost brand new (battery indicator says like 40 days idle battery) and i get "more days" battery after driving so the generator must be working...

The driver door opens normally when using the inner open button so the latch mechanism works, the window Passenger door and window works perfectly, the car starts and drives normally...

The main instrument display is now always on with the McLaren car visible and does not go away even when the car has been locked for 30 minutes.

Any ideas? Dealer is closed weekends and I was planning on attending a car event with the car tomorrow morning...
 

·
Premium Member
Joined
·
855 Posts
I washed my new-to-me 2016 570S for the first time today. All of the sudden the driver side window went completely down, and the button to open the driver door is no longer working... If i try to raise the driver side window it responds normally but immediately goes back all the way down when reaching the top or when i release the button.

I tried locking, unlocking, holding the remote lock button for a whole minute, trying with the engine running, closed the door with soft close and firmly all the way, tried the window position re-set by holding both window switches down for 5 sec and then up for 5 sec. Nothing works. Plugged in OBD2 adapter and no fault codes are present.

I have been out driving for like 6 hours before the wash so the battery should be fully charged.

There are no fault codes visible on the dash, though earlier today while driving i got a "Battery management active" message but i had been driving for hours and the battery is almost brand new (battery indicator says like 40 days idle battery) and i get "more days" battery after driving so the generator must be working...

The driver door opens normally when using the inner open button so the latch mechanism works, the window Passenger door and window works perfectly, the car starts and drives normally...

The main instrument display is now always on with the McLaren car visible and does not go away even when the car has been locked for 30 minutes.

Any ideas? Dealer is closed weekends and I was planning on attending a car event with the car tomorrow morning...
I would personally try disconnecting the battery for an hour. In the front trunk, remove the middle panel, disconnect the left connector on the battery (ground), then leave it for an hour, and reconnect. Just 10 mins might be fine, but I’d leave it for an hour just to make sure everything resets. Before doing it make sure the car has gone in to sleep mode first. Basically unlock the car, open the door (you can close it again if you like), open the trunk, wait >2 mins for the car to return to sleep mode (time, odometer, etc should disappear - car is in low power mode). Then disconnect the battery. Read about sleep mode on page 2.2 of the owners manual.

Here is the relevant section of the McLaren service manual:



I've never done the nose lift maintenance thing and not had any issues. I've actually disconnected with the lift up or down, with no issues either way. I guess disconnecting with the lift down though is probably safer (resting state).

Thanks!

Z.
 

·
Registered
Joined
·
8 Posts
I would personally try disconnecting the battery for an hour. In the front trunk, remove the middle panel, disconnect the left connector on the battery (ground), then leave it for an hour, and reconnect. Just 10 mins might be fine, but I’d leave it for an hour just to make sure everything resets. Before doing it make sure the car has gone in to sleep mode first. Basically unlock the car, open the door (you can close it again if you like), open the trunk, wait >2 mins for the car to return to sleep mode (time, odometer, etc should disappear - car is in low power mode). Then disconnect the battery. Read about sleep mode on page 2.2 of the owners manual.

Here is the relevant section of the McLaren service manual:



I've never done the nose lift maintenance thing and not had any issues. I've actually disconnected with the lift up or down, with no issues either way. I guess disconnecting with the lift down though is probably safer (resting state).

Thanks!

Z.
Thanks for your help!

I first tried to remove the fuse to the driver door which did remove the "error state" that kept the McLaren car image stay permanently on the dashboard, however it re-appeared when i reconnected the fuse.

I now disconnected the battery and having fingers crossed that it resolves the issue...

I think the problem is that the car has lost connection with the door open button and as a safety measure it lowers the window so you can open the door from inside and wont let it go up. Strange that it does not display any error on the dashboard for this.

The reason might have been that water got into the button while i was washing and created a short or something, if it was intermittent the battery reset process might help, if its permanent I think I will need to replace the button.

The car event starts in 40 minutes so this is my last chance at getting it working to make it there in time.

I will search for the service manual on how to remove the button to inspect it if its an easy process...

Thanks again for your fast help!
 

·
Registered
Joined
·
160 Posts
Realistically, how many of these cars have electronic issues? That's all I hear about. This is scaring me about the brand.
Don’t let it scare you out of the brand. The electronic issues are super minor and almost always fix themselves. It’s a mild inconvenience that happens occasionally.

I’m my opinion you can’t beat mclaren right now.
 

·
Registered
Joined
·
10 Posts
Hi all,

Just bought my dream car, a 03/2017 570s track pack with 6800km on it. I love it and was so happy to get it but my 2 first days with it on my way back from Germany to Switzerland were a real nightmare.

First, after some hard drive on small road, I figured that the ESC was stopping the car quite hard, never had that even with a tuned m4 with much less traction than this 570s.

Second, engine fault came also the same day during the driving. No limp mode so I though it was not a big deal but still...

I went to sleep qt the hotel since I couldn t get my dealer on the phone and it was already 7pm. Next monring, I got him on the phone..FYI, the car has been completely checked since I had requested 1 year of extended warranty even if th car was still under the 3 official years of warranty until March 2020. He was very achamed and dicussed direclty to the aftersale to have his opinion. They told me to go to the clothest dealer who was just about 1h30 hour away from me. I went there and my engine fault was just a Catalysor issue. Can be sensor or the part itself but I can continu my way back home.

Third issue when I was on the german highway at around 250km/h so far from the top speed...A part of the front bumper just went off, damging the driver door on the way an a minor damage on the rear fender too...

Last one, the Iris buttom falled and has 2 fixation broken, not the huge issue but still..

The dealer was again very ashamed and told me that if warranty won t cover this, he will. I was pleased to hear that but was and still am a bit disgusted by the car. I mean, all those after 2 days. How can I trust the car now.

The car went to Geneva dealer for fix but he told me that since summer period, it could get longer for the car to be fixed...I hope that the car will come back in perfect condition and without any new problem any time soon


Screenshot_20190709-155210_Gallery.jpg


194983


194984


194985


194986


194987


194988
 

Attachments

·
Registered
Joined
·
43 Posts
Sorry to hear about your bad luck. Curious which dealer it was in Germany... I bought a 570S last summer in Germany and had lots of issues. They claimed they too did the full warranty inspection but I had several issues. I even got them to specifically check the wings as it’s a very common issue that they fly off because they were not put back properly say by somebody putting PPF on. When I got the car back to NL I took it to my dealer and asked them to redo the entire warranty check and found multiple issues including incorrectly fitted wings.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
263 Posts
since your car is a 16' model year there have been several software updates that have taken care of many of the electrical gremlins. I would suggest having a dealer install these updates which should help.
 

·
Registered
Joined
·
3 Posts
Hello i am new here and new to mclaren , I need some help. I have a 570s with 4k km. yesterday my wiper got stuck on the upright position and doesn't want to go back. i had the same problem before when i forgot to charge the battery but it was fine after charging . this morning after using the charger i tried the lock and unlock procedure hoping the wipers will reset then started the car, still nothing. i then sprayed the windshield with water and the wipers moved back to the off position. then it wouldn't work anymore. there were no error messages in the screen. hoping that someone might be able to help me. unfortunately there is no Mclaren dealer at the moment where i am .
 

·
Registered
Joined
·
43 Posts
Hello i am new here and new to mclaren , I need some help. I have a 570s with 4k km. yesterday my wiper got stuck on the upright position and doesn't want to go back. i had the same problem before when i forgot to charge the battery but it was fine after charging . this morning after using the charger i tried the lock and unlock procedure hoping the wipers will reset then started the car, still nothing. i then sprayed the windshield with water and the wipers moved back to the off position. then it wouldn't work anymore. there were no error messages in the screen. hoping that someone might be able to help me. unfortunately there is no Mclaren dealer at the moment where i am .
I don’t have a specific solution for this but have been told to do a hard reset if you get strange symptoms like this... which involves disconnecting the battery and reconnecting it.


Sent from my iPhone using Tapatalk
 

·
Sponsor
Joined
·
755 Posts
So, I have begun the organization of the 570 coupe and I will add the 570 spider as a combined Workshop service Manual. I would like a minimum of 25 buyers. I will set the price at that par level to 800.00. If I get 30 buyers, then 750.00 each. Repair instructions, parts, wiring diagrams. I will start another thread, eventually. For now, PM me with commitment and I will generate a list in my new thread. It takes a super long time to get this done but I will be done prior to the group buy ending. My P11 manual was a huge hit, this will be no different.

edited: Because of the addition of the spider!

XPRD
 
161 - 180 of 208 Posts
Top