McLaren Life banner

181 - 200 of 208 Posts

·
Registered
Joined
·
341 Posts
Here are the issues I've noted so far with my 2mo ownership of my new to me 2017 570s track pack:

1. Alcantara bubble in pass. A pillar - dealer is replacing.
2. Driver A pillar was loose - dealer fixed.
3. AC doesn't work at times. Sometimes it literally stops blowing cold like the compressor isn't running. Also, it takes forever it seems to even start up when the car and IRIS start. It also doesn't raise idle when on half the time. Dealer couldn't verify and said it was on the most current software. On a drive yesterday I swear the compressor felt grubbly. I wonder if it's going?. :(
4. Idle is poor- likely from above AC load without increasing speed. However, at start up yesterday the exhaust almost sounded like it had a missing noise. No CEL or anything and it drives fine. Maybe a coil pack on the way out?
5. BIG ISSUE- The car was spec'd per window sticker and verified with VIN with front lift and it doesn't have it! Dealer said Mclaren said they wouldn't do anything as I'm a subsequent owner. I called BS. I'm an attorney and will be making a claim directly with Mclaren. I have standing as a subsequent purchaser, and the car is still under warranty and there are other warranty claims based on options - merch, fitness, etc. To even get that info from the dealer btw was a real pain. :(
6. 2nd BIGGER ISSUE- After a spirited drive for a good 3h, I noted coolant on the ground in front of the rear tires the next day. I took it to the dealer for all the above and this. Dealer declined saying the bottom plastic end tanks on both radiators in front of the rear wheels have cracks and it was caused by improper lifting or road debris. Anyone have a 570s maintenance manual for the R&R? I was thinking of just pulling them and having a radiator shop professionally repair and test. Local dealer wanted 7k! Mclaren Boston quoted 3.2k for both new rads. :( I don't otherwise know what to do.
7. Windows don't operate as one touch from time to time.
8. Similar to others, Rattles in cab. - I fixed by tightening the undertray and moving the passenger carbon bucket forward off the rear bulkhead.
9. IRIS crashed. Dealer said it's on most current software and couldn't verify.
10. Track pack data doesn't write to USB. Dealer told me that wasn't a function until I showed him the manual. They are allegedly still investigating. :(
11. Driver door was not aligned well. Dealer adjusted but it's now out instead of low. :(


Otherwise, I really love the car. It is everything and more I've wanted out of it which is very rare for me. Thanks!
 

·
Registered
Joined
·
152 Posts
Ok, so this seems to be the place to ask quick tech questions in lieu of starting new threads...


My 2019 Spider was purchased 5 months ago. I just got a message from the ECU that says i need to service the car in 5 days. Does this mean that the one year service is actually based on the date of production (which is Aug 2018, so close enough), and not the purchase date?

I guess this is more complaint than question, since that seems logically what’s happening. But i’m not prepared for the expense because this is not how i’m used to these things working...sigh
 

·
Owner
Joined
·
491 Posts
Here are the issues I've noted so far with my 2mo ownership of my new to me 2017 570s track pack:

1. Alcantara bubble in pass. A pillar - dealer is replacing.
2. Driver A pillar was loose - dealer fixed.
3. AC doesn't work at times. Sometimes it literally stops blowing cold like the compressor isn't running. Also, it takes forever it seems to even start up when the car and IRIS start. It also doesn't raise idle when on half the time. Dealer couldn't verify and said it was on the most current software. On a drive yesterday I swear the compressor felt grubbly. I wonder if it's going?. :(
4. Idle is poor- likely from above AC load without increasing speed. However, at start up yesterday the exhaust almost sounded like it had a missing noise. No CEL or anything and it drives fine. Maybe a coil pack on the way out?
5. BIG ISSUE- The car was spec'd per window sticker and verified with VIN with front lift and it doesn't have it! Dealer said Mclaren said they wouldn't do anything as I'm a subsequent owner. I called BS. I'm an attorney and will be making a claim directly with Mclaren. I have standing as a subsequent purchaser, and the car is still under warranty and there are other warranty claims based on options - merch, fitness, etc. To even get that info from the dealer btw was a real pain. :(
6. 2nd BIGGER ISSUE- After a spirited drive for a good 3h, I noted coolant on the ground in front of the rear tires the next day. I took it to the dealer for all the above and this. Dealer declined saying the bottom plastic end tanks on both radiators in front of the rear wheels have cracks and it was caused by improper lifting or road debris. Anyone have a 570s maintenance manual for the R&R? I was thinking of just pulling them and having a radiator shop professionally repair and test. Local dealer wanted 7k! Mclaren Boston quoted 3.2k for both new rads. :( I don't otherwise know what to do.
7. Windows don't operate as one touch from time to time.
8. Similar to others, Rattles in cab. - I fixed by tightening the undertray and moving the passenger carbon bucket forward off the rear bulkhead.
9. IRIS crashed. Dealer said it's on most current software and couldn't verify.
10. Track pack data doesn't write to USB. Dealer told me that wasn't a function until I showed him the manual. They are allegedly still investigating. :(
11. Driver door was not aligned well. Dealer adjusted but it's now out instead of low. :(


Otherwise, I really love the car. It is everything and more I've wanted out of it which is very rare for me. Thanks!
Well, this would be frustrating. I think you are getting the run around which is BS. My 2017 Tack Pack car has none of these issues. It's so good I don't want it to go in for the airbag recall in case they screw something up!

You may need a different dealer. I may have a line on a 12C manual. PM your email.
 

·
Registered
Joined
·
57 Posts
Talking about airbag recall, I saw a picture of the interior carnage during airbag replacement somewhere here. It makes me scared to bring it in. My 570s has 0 issues & I want to keep it that way.
 

·
Registered
Joined
·
341 Posts
I have the 12c manual. I paid the $30 for an hour for the real one for a 570. Significantly better.

Well, this would be frustrating. I think you are getting the run around which is BS. My 2017 Tack Pack car has none of these issues. It's so good I don't want it to go in for the airbag recall in case they screw something up!

You may need a different dealer. I may have a line on a 12C manual. PM your email.
 

·
Registered
Joined
·
9 Posts
Just had my 570s in for service and had them check a resume in the door and behind the seats. Here is an email as to what was wrong. "Good morning. Yes I have found the rattle and the noise behind drivers side area. It was the b pillar behind the seat not secured properly but also there was a clip for the speaker grill that was loose and causing a high pitch vibration. The b pillar noise sits on a door seal and that is why it sounded like there was something coming from drivers side door. All taken care of. "
 

·
Registered
Joined
·
341 Posts
It is. Anyone have a better number for Mclaren customer service? I got a bizarre number that sounds like a cell phone voicemail from the local dealer.

Well, this would be frustrating. I think you are getting the run around which is BS. My 2017 Tack Pack car has none of these issues. It's so good I don't want it to go in for the airbag recall in case they screw something up!

You may need a different dealer. I may have a line on a 12C manual. PM your email.
 

·
Registered
Joined
·
152 Posts
got a "clutch temperature high" warning. drove it for two hours in 85F temperatures. mainly highway driving, probably redlined it 3-4 times because i can't resist tunnels. no launches. i live in Florida so i LOL'ed when i read the bit about "driving up hills"

the fault cleared when i followed the owner's manual recommendation to let the car idle for a few minutes.

normal?


MESSAGE: Clutch temperature high

ACTION: The vehicle has been subject to extreme operating conditions. This may be caused by excessive hill starts, repeated hard acceleration, driving slowly up steep hills for extended periods. As a result, the gearbox may limit engine torque.

Stop the vehicle and allow the engine to idle in neutral for a few minutes.
 

·
Registered
Joined
·
17 Posts
The 570s manual is finally done. I need to proof read it. PM me for payment details. It came out very nice!

Thanks
Very nice is an understatement!

Simple DropBox pull and seamless integration in OneNote. At first I was thinking I'd want a PDF and just trudge through that to find what I need but the whole OneNote format for me is superior. I am no power OneNote user and was easy to figure out.

If I need any pages likely would just print them out.

Just wish I could use the active links to order my own parts. :)

Thanks XPRD totally satisfied and ready to install the orange belts from you now that I know exactly how to go about it!!
 

·
Sponsor
Joined
·
750 Posts
Very nice is an understatement!

Simple DropBox pull and seamless integration in OneNote. At first I was thinking I'd want a PDF and just trudge through that to find what I need but the whole OneNote format for me is superior. I am no power OneNote user and was easy to figure out.

If I need any pages likely would just print them out.

Just wish I could use the active links to order my own parts. :)

Thanks XPRD totally satisfied and ready to install the orange belts from you now that I know exactly how to go about it!!
For those who want clarification on this post, @Dezracer bought a 570 coupe manual and he is happy with his investment. I can provide a spider manual at a small additional cost. Please PM me whenever you are ready.

XPRD
 

·
Registered
Joined
·
6 Posts
XPRD did an outstanding job! Worth very cent . This manual is has already helped with several issues I had. Get it, you won't be dissappointed.
 

·
Registered
Joined
·
22 Posts
I am sorry Not sure if this is the right forum . PLEASE HELP

NEED HELP PLEASE ! I have a 2018 570s with 4k km . It was about 2 weeks ago since the last time i had driven the 570s . everything was fine. Car was parked for 2 weeks and Ctek charger was on.
i started the car yesterday and it started normally No faults battery is 97 percent i let it run for a few minutes to warm it up then i placed it on 1st gear. i stepped on the gas pedal and it wouldn't move ...pressed GAS PEDAL harder and the RPM WOULDNT GO UP PASS 1500. CAR WAS LITERALLY JUST CRAWLING. ITS SO BAD IT WOULDNT GO UP THE RAMP. SAME THING ON REVERSE. I looked at the Cluster NO faults No msgs. DID the Cycle start ,stop and lock unlock
a few times . same thing. Then i noticed that the car Starts even without stepping on the brake pedal which is a safety feature of most cars. How can this be happening ! my friend who came, noticed that my third brake light stayed ON without anyone pressing the brake pedal. SO as soon as the car powers on the brake lights are on. like someone is on the pedal. even with the EPB disengaged the light stays on. the pedal feels like its halfway pressed.
My Problem is that there are No Mclaren dealer in the country. I wrote Mclaren an email asking for assistance. sent it to The main Client services in UK. they replied and gave me a number of a dealer in the closest country to me. Thats OK but when i called that dealer i was then referred to another dealer in that country because they said that other dealer can better communicate in English. OK I called that other dealer talked to someone who is kinda helpful , told her i needed to possibly speak to a technician. She said she is more than happy to translate. OK i kept my patience . told her my problem. She said she's gonna email me me back . i waited for the email .whole day. Nothing. SO i called back. I was told that i needed to be referred to another country . Unbelievable. I currently have Ferraris and Porsches Lambos Never was i in this situation. For the Money I paid for that car. I call from the manufacturer rep would be nice. TERRIBLE SERVICE! I wrote to them again and demanded that they make arrangements for me.That was this morning . Felt like i am running in circles.I hope a Mclaren Executive reads this. PLEASE HELP.
 

·
Super Moderator
Joined
·
4,446 Posts
Discussion Starter #198
I am sorry Not sure if this is the right forum . PLEASE HELP

NEED HELP PLEASE ! I have a 2018 570s with 4k km . It was about 2 weeks ago since the last time i had driven the 570s . everything was fine. Car was parked for 2 weeks and Ctek charger was on.
i started the car yesterday and it started normally No faults battery is 97 percent i let it run for a few minutes to warm it up then i placed it on 1st gear. i stepped on the gas pedal and it wouldn't move ...pressed GAS PEDAL harder and the RPM WOULDNT GO UP PASS 1500. CAR WAS LITERALLY JUST CRAWLING. ITS SO BAD IT WOULDNT GO UP THE RAMP. SAME THING ON REVERSE. I looked at the Cluster NO faults No msgs. DID the Cycle start ,stop and lock unlock
a few times . same thing. Then i noticed that the car Starts even without stepping on the brake pedal which is a safety feature of most cars. How can this be happening ! my friend who came, noticed that my third brake light stayed ON without anyone pressing the brake pedal. SO as soon as the car powers on the brake lights are on. like someone is on the pedal. even with the EPB disengaged the light stays on. the pedal feels like its halfway pressed.
My Problem is that there are No Mclaren dealer in the country. I wrote Mclaren an email asking for assistance. sent it to The main Client services in UK. they replied and gave me a number of a dealer in the closest country to me. Thats OK but when i called that dealer i was then referred to another dealer in that country because they said that other dealer can better communicate in English. OK I called that other dealer talked to someone who is kinda helpful , told her i needed to possibly speak to a technician. She said she is more than happy to translate. OK i kept my patience . told her my problem. She said she's gonna email me me back . i waited for the email .whole day. Nothing. SO i called back. I was told that i needed to be referred to another country . Unbelievable. I currently have Ferraris and Porsches Lambos Never was i in this situation. For the Money I paid for that car. I call from the manufacturer rep would be nice. TERRIBLE SERVICE! I wrote to them again and demanded that they make arrangements for me.That was this morning . Felt like i am running in circles.I hope a Mclaren Executive reads this. PLEASE HELP.
If you don't mind doing work on your own car, or have mechanics you trust locally, you might want to send a DM to XPRD and see about getting one of his service manuals. If you scroll up to earlier posts in this thread you'll see more info on this.

-Jamie.
 

·
Registered
Joined
·
160 Posts
3. AC doesn't work at times. Sometimes it literally stops blowing cold like the compressor isn't running.
2019 570S - exactly the same issue. Sometimes blows warm air only out of the top / windshield vent. Car needs to be stopped / started again to resolve.
 

·
Registered
Joined
·
160 Posts
Regarding the AC issue - my car is in service at the moment having various issues looked at. They said they needed to "recalibrate" the system and it should work fine now.
 
181 - 200 of 208 Posts
Top