McLaren Life banner

1 - 20 of 24 Posts

·
Registered
Joined
·
432 Posts
Discussion Starter #1
Took my 12C to MSR in Houston yesterday. Like most people have said; very fast and great steering feel.
Comically, I was "black flagged" after a few laps when the flag-man thought that "something was comming loose" in the back spoiler. He was quite embarased when he realized it was the brake flap.:D
I was very dissapointed, however, when the error message "Engine System fault" came on after only a few warm-up laps.:mad: I had to stop immediately, since I noticed a marked drop in performance. Temperature and oil pressure where fine. The error message is still on, despite cool down. I'm sure the car whent into "safe" mode, but it ruined the rest of the day. I have a call into the dealer to see what's up. I have another track day friday, and hope it will be resolved by then.
I've also noticed condensation inside the front headlamps when washing the car. I'm concerened this is from improper sealing.:(
I really love the car, but my issues are starting to add up...:(
 

·
Registered
Joined
·
4,955 Posts
Umm, Moncho, bad luck to get that on a track. Let us know what the issue was, after all I think Mclaren are a racing car company!!!

Regarding the headlights let them know, it's a first I think.

My car at 1500 miles is largely fault free so far, in fact it is fault free mechanically. Will do 1500 miles in next 5 days so we will see.
 

·
Registered
Joined
·
1,330 Posts
Moncho

I'm at MSR next weekend (Sunday April 1st) for a track day with the Texas Speed syndicate.

Did you check your tire pressures? I'm told that a 3psi differential will put the car into safe mode, so maybe it was this???

I'll let you know how I get on next weekend - I can't wait! In fact I'm driving home really early Sunday morning from the Texas Cobra Club Rally in San Marcos so I can head down to MSR - talk about going from the Ridiculous (427SC( to the Sublime (MP4-12C)!
 

·
Registered
Joined
·
886 Posts
Be sure to get it to your dealer.
 

·
Registered
Joined
·
107 Posts
I've also noticed condensation inside the front headlamps when washing the car. I'm concerened this is from improper sealing.:((
I have had some condensation in one headlight, the dealer said they'd take care of it when the car is next in.
 

·
Registered
Joined
·
4,955 Posts
I was very dissapointed, however, when the error message "Engine System fault" came on after only a few warm-up laps.:mad: I had to stop immediately, since I noticed a marked drop in performance. Temperature and oil pressure where fine. The error message is still on, despite cool down. I'm sure the car whent into "safe" mode, but it ruined the rest of the day. I have a call into the dealer to see what's up. I have another track day friday, and hope it will be resolved by then.
(
Moncho. I remember a car going into 'limp mode' when It decided it over-revved on the down change (no red line limit). Do you think this could be a possible cause as I find the car is always going faster than I think..........no swipe at driving skills........just a thought.
 

·
Registered
Joined
·
432 Posts
Discussion Starter #9
Moncho. I remember a car going into 'limp mode' when It decided it over-revved on the down change (no red line limit). Do you think this could be a possible cause as I find the car is always going faster than I think..........no swipe at driving skills........just a thought.
The car is so quiet and composed that I did hit the rev limiter on the way up once, but this was a few laps before the warning came on. It takes a little time getting used to the engine not screaming in your ear for a gear shift.:)
The car was picked-up today, and on it's way to the dealer. We'll see...

Ps. You can swipe my driving (lack of) skills all you want. I'm a realist.:)
 

·
Registered
Joined
·
886 Posts
FYI. The gear indicator turns red, from orange, when it is close to time to upshift and then an arrow up lights up when you really need to shift. I found power falls off and shifts should occur around 8,000.
 

·
Registered
Joined
·
4,955 Posts
Ok, I'm talking about over revs on the DOWNSHIFT as there is NO rev limiter in most cars and the engine manager, let's call him Dave, says sod this I'm not playing so goes into limp mode. Not about up shifts.
 

·
Registered
Joined
·
432 Posts
Discussion Starter #12
Ok, I'm talking about over revs on the DOWNSHIFT as there is NO rev limiter in most cars and the engine manager, let's call him Dave, says sod this I'm not playing so goes into limp mode. Not about up shifts.
I understand what you mean... that did not happen, not on downshift.
 

·
Registered
Joined
·
1,194 Posts
Probably a software glitch but its still disheartening to hear it.

BTW, are you member at MSR - Houston? It is by far my least favorite track in Texas. I would recommend taking it to TWS instead. Much more wide open track with seriously high speeds. I got my GT3 up to 150 on the banked front straightaway. Can't wait to try it with the McLaren.
 

·
Registered
Joined
·
432 Posts
Discussion Starter #14
Probably a software glitch but its still disheartening to hear it.

BTW, are you member at MSR - Houston? It is by far my least favorite track in Texas. I would recommend taking it to TWS instead. Much more wide open track with seriously high speeds. I got my GT3 up to 150 on the banked front straightaway. Can't wait to try it with the McLaren.
Not a member. I was a corporate (FREE!) event and close to home. I have a track day this friday at Eagle's Canyon in Dacatur. I hope they'll have the car ready.:(
 

·
Registered
Joined
·
432 Posts
Discussion Starter #15
Got the dreaded call from the dealer... No go for friday. Apparently one of the turbos needs to be replaced. Very disappointed.:(
 

·
Registered
Joined
·
886 Posts
While it is a bad situation it is much better to get it sorted now. Let us know how it goes.
 

·
Registered
Joined
·
1,330 Posts
Wow! That's not a call I'd like to get, Moncho. Hopefully the dealer/factory will run a ton of diagnostics to determine cause.
 

·
Owner
Joined
·
166 Posts
Moncho

I'm at MSR next weekend (Sunday April 1st) for a track day with the Texas Speed syndicate.

Did you check your tire pressures? I'm told that a 3psi differential will put the car into safe mode, so maybe it was this???

I'll let you know how I get on next weekend - I can't wait! In fact I'm driving home really early Sunday morning from the Texas Cobra Club Rally in San Marcos so I can head down to MSR - talk about going from the Ridiculous (427SC( to the Sublime (MP4-12C)!
Def nothing to do with tyre pressure. I can get mine from 29/33 to well over 45psi on track.
 
1 - 20 of 24 Posts
Top