McLaren Life banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
What’s up folks!
Tonight since I was driving my 720s, I found it was barely hot inside.
Later on found my climate system was not working.
I parked in a plaza and restarted the car, still have the problem.

Later on, on my way home, I found there a error message on my battery “Battery fault “ (not showing the message center)

Did anyone got this problem before?

Any suggestions on fixing it?

I am so appreciate for the helps!
212659
 

·
Registered
Joined
·
298 Posts
Could be a ground issue. Might want to check to see if your ground is attached tightly. (PS. Never had an issue with my 720, but have on one of my others)...
 

·
Registered
Joined
·
124 Posts
I had a weird battery issue where it would say my battery was at some very low level (say 2%), and shut down unnecessary electronics such as my power seats, and then after 5 or so miles of driving, would suddenly jump to 100% and work perfectly from then on. This problem happened to me twice in 7000 miles. My dealer did a software upgrade which probably fixed it, though it remains to be seen, as the issue is so rare. I did not get a "fault" message, though. At any rate, apparently there may be battery issues fixable via software, maybe.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I appreciate for all the helps.

I have asked my experienced friend and he told me how to fix it.
This should be a rear software issue and usually happens when you stop driving it for a while.

Here are the steps I did to fix:
1. Drive the car for 20 mins
2. Park and shut it down for 10-15mins
3. Restart

Can be fixed easily.
 

·
Registered
Joined
·
13 Posts
Had exactly the same issue, yesterday. Restarted the car twice, went for a 10 minute drive and the fault cleared
 
1 - 6 of 6 Posts
Top