McLaren Life banner

1 - 20 of 21 Posts

·
owner
Joined
·
38 Posts
Discussion Starter #1
My 650 has been at McLaren of Chicago for over a month, and they can't seem to fix it ... so I am turning to you guys for help. I fired up the 650 after ~4 months in climate controlled storage and as I was loading it on the trailer i heard a strange "warning" sound in the interior and the gauge cluster had a fault that said something like "pull vehicle over" ... or something to that affect. I quickly turned off the motor and fired it back up a few minutes later with no faults or warning sounds. The car was heading to McLaren of Chicago for annual maintenance and so i didn't think much of it as i was sure it threw a code they could read/fix. Well, the vehicle has been at the shop for a over a month and they have been able to repeat the sound/fault several times, but it does not show up when they scan for the fault. They are at a loss as to the root cause/fix.

Has anyone had something similar happen? Any input is greatly appreciated!
 

·
owner
Joined
·
38 Posts
Discussion Starter #3
Twinscroll - thanks for the input! The car is a 2015 and i believe the battery is original unless they replaced it as part of their annual routine maintenance program. I've had the dealer follow their suggested program each year, but can't remember if they replaced the battery. Do you suggest I replace it given it's a 2015?
 

·
Registered
Joined
·
284 Posts
Twinscroll - thanks for the input! The car is a 2015 and i believe the battery is original unless they replaced it as part of their annual routine maintenance program. I've had the dealer follow their suggested program each year, but can't remember if they replaced the battery. Do you suggest I replace it given it's a 2015?
I'd have them test it. They should have the proper tools to do such.
 

·
Recent Convert
Joined
·
860 Posts
Battery is not on routine list
These are very prone to these sorts of glitches with low voltage
Battery control module can also be an issue
 
  • Like
Reactions: Twinscroll

·
owner
Joined
·
38 Posts
Discussion Starter #6
Thanks guys! They are too busy working on theairbag recall to get at this immediately, but i will post the eventual outcome!
 
  • Like
Reactions: Twinscroll

·
Registered
Joined
·
273 Posts
Yep mine has done it a couple time and i just turn off and back on and it’s fine.

Could be air sound generator leak they are known for making them have strange glitches , easy fix with a block off plate from XPRD.
 

·
owner
Joined
·
38 Posts
Discussion Starter #8
Thanks 12cKid! I will have them check the ISG.
 

·
Registered
Joined
·
180 Posts
Could of just been a glitch. I know if it is electrical or a glitch, impossible to find unless it is acting up. Low voltage does do strange things but it sounds like your problem might be isolated event and not to worry if they cant find anything. Make sure it is documented in case it appears and there is warranty left. FYI

Mike
 

·
owner
Joined
·
38 Posts
Discussion Starter #10
The "good news" is they are able to repeat the fault ... the bad news is it doesn't kick out a code of any sort when they scan. The other bad news is they are no longer working on the car because they have so many airbag replacements that need to be done and they are very short on technicians. Hoping to have it back before it begins to snow again :(
 

·
owner
Joined
·
38 Posts
Discussion Starter #11
Update: still no fix ... car continues to throw the fault, and has been at Chicago McLaren since mid-March. Nothing quite like owning a rapidly depreciating "asset" that you don't get to use. Ugh.
 

·
Registered
Joined
·
4,955 Posts
ONE ISSUE ABOUT REBOOTING.

The key has to be walked away so it's not in proximity.......then it reboots.

It's easy to forget this.
 

·
Registered
Joined
·
4,955 Posts
The second issue, if a car is not moved with the engine on at least a few metres on a regular basis then the gearbox does not lubricate and the sensors throw a wobbly.

So if your car has been static perhaps it needs taking around the block when the oil is warm........this is the dark side of 'modern' electronics......
 

·
owner
Joined
·
38 Posts
Discussion Starter #14
roudnincircles; thanks for the tips. They have been driving the car regularly and the issue persists. Thanks for the tip regarding the proximity of the key ... i will forward that info to them. They "love it" when i have suggestions :)
 

·
owner
Joined
·
38 Posts
Discussion Starter #15
It's been 90+ days of this vehicle being at the McLaren dealer without a fix. They are communicating with me on a regular basis, but they don't seem to be making any progress. Do I have any realistic recourse (i.e., based on your past experiences)?

The vehicle is a 2015 and still under factory warranty. I am not typically a litigious person, but starting to think I may need to "lawyer up".

Thanks, in advance, for any suggestions.
 

·
owner
Joined
·
38 Posts
Discussion Starter #17
smokeygt - your timing is impeccable ... i received the vehicle back last night and planned on providing an update today. The problem appears to have been something with the lift system in the rear of the vehicle (didn't even know the rear end lifted?!?!). Anyway, they replaced a lot of parts until they finally decided the lift system may be the culprit. It's been a long 5 months of waiting, and i am hoping the problem is gone! PS, the hauler had a trailer with a side door that was cut specifically for McLaren doors to open while still in the trailer ... wish I would have thought of that for my trailer!
 

Attachments

  • Like
Reactions: rnixon

·
Registered
Joined
·
2,550 Posts
Wow what a saga I am sure you were happy to see Chris pull up with the trailer for sure after being without the car that damn long I hope you talk to McLaren customer service to make it right for the car being gone that long
 

·
Registered
Joined
·
267 Posts
I hope they figured it out. These gremlins are sometimes hard to find. And frustrating. If it can happen to you, it can happen to any of us. Thanks for sharing with the rest of us.
 

·
owner
Joined
·
38 Posts
Discussion Starter #20
Wow what a saga I am sure you were happy to see Chris pull up with the trailer for sure after being without the car that damn long I hope you talk to McLaren customer service to make it right for the car being gone that long
Yes, was very happy to see Chris show up (great guy/hauler). Do you have a phone number for McLaren customer service? The dealer refused to do anything for me, but I think McLaren should at least extend my warranty for the amount of time it was out of commission (i.e., 4 months). It's been frustrating especially given how short summers are in MN.
 
1 - 20 of 21 Posts
Top