McLaren Life banner
1 - 5 of 5 Posts

Registered
Joined
12 Posts
Discussion Starter · #1 ·
Hi, there guys, new to the McLaren life, bought a McLaren 570s from a private guy, and the next day I start it it starts running terribly.

Maybe one of you guys has had a similar problem/problem and I would appreciate some help.

Mclaren 570S 2016 55,000KM (34k miles)
The car misfires in cylinders 1;2;3;4 so only one side, I have cleaned the fuel injectors and replaced the spark plugs as well as I switched the ignition coils from one side to the other side, same with sensors and throttle bodies, it got a bit better but still.
The car basically barely goes up to 4k RPMs, and then after that works as it needs to, but not every time, I was thinking it might be the throttle body not opening correctly but not sure how to check them.
As well as the fuel ratio I feel like is off as it spits flames out of the right side exhaust.
When the car is cold it acts fine, at the moment it warms up when I stop it just dies on me, i was thinking maybe it might be the DLD but as i reaserched moreabout that i don't think it is that, no rattling sound on idle and no misfires on 5;6;7;8.
I have taken it to services around me, and i feel like they are just guessing, what and how, as each of the 6 services told me a different thing. Starting with removing the engine, to changing the battery to changing the gearbox...., for me it sounds absurd.
Any tips would help. Keen on fixing it myself as non of my past supercar mechanics do mclarens 馃槗
 

Registered
Joined
8,863 Posts
Cam shaft variators on one bank?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top