Overheating 570S - normal ride. - McLaren Life
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 Old 06-09-2017, 11:38 AM Thread Starter
 
Join Date: Jun 2017
Posts: 2
Overheating 570S - normal ride.

Hi, i have a 570S with problem. Coolant is high temperature and enters the orange field. This will happen even in a normal ride. Is it possible that the thermostat is wron g?Thx for answer.
Masakr_Petrov is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-09-2017, 05:34 PM
 
Ducati1199's Avatar
 
Join Date: Jan 2016
Location: San Fran - East Bay
Posts: 834
Early cars had a few issues with hose clamps either being loose or working loose. I know of one car that dropped it's coolant on the track. Other than getting dealer involved I'd suggest checking that you haven't lost coolant.
It's not impossible for thermostat to be broken - a few 991.1 GT3's had broken thermostats that I know of but not heard of any on 570?

Last edited by Ducati1199; 06-09-2017 at 08:07 PM.
Ducati1199 is offline  
post #3 of 7 Old 06-09-2017, 06:17 PM
 
Join Date: Apr 2015
Posts: 3,850
Quote:
Originally Posted by Masakr_Petrov View Post
Hi, i have a 570S with problem. Coolant is high temperature and enters the orange field. This will happen even in a normal ride. Is it possible that the thermostat is wron g?Thx for answer.
The thermostat is a 3 way device and has failed in other McLaren models. Have not heard of any 570 thermostat fails.
Do you see any signs of coolant leakage under your car? Also do you smell any glycol?
Best to take into Dealer if possible.
eMcL is online now  
 
post #4 of 7 Old 05-16-2019, 05:04 PM
 
Join Date: Apr 2019
Posts: 8
You might have run out of coolant just from ambient temperature or it may just be a little low.
TwnTrbo is offline  
post #5 of 7 Old Yesterday, 03:31 AM
 
Join Date: Nov 2018
Posts: 70
Check coolant(check for leak under car)
I had a hose slit


Sent from my iPhone using Tapatalk
Anes570s is offline  
post #6 of 7 Old Today, 12:25 AM
 
Join Date: Feb 2018
Posts: 32
Exact same thing happened on my 2017 570s like 3 weeks after buying it brand new . They said thermostat was stuck closed. Replaced it under warranty and never had an issue again
AirdrieVentador is offline  
post #7 of 7 Old Today, 12:48 AM
 
Join Date: May 2018
Posts: 26
Besides from the above suggestions: low coolant, faulty thermostat, it could also be a problem with the water pump and if the temperature rises mostly in traffic the cooling fans may not be operating.
Suggest not driving the car with an overheat condition since it may lead to head warpage and/or head gasket failure which could be denied under warrany due to "reglect or abuse."
Doctor Mark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the McLaren Life forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome